Cannot encrypt files with Kleopatra

I have a headache inducing problem with Kleopatra. I tried encrypting files several times but after selecting the file I want to encrypt the second window does not appear. I tried looking at the task managed but no results. When I try to close the program It gives me a warning stating that there are ongoing operations in the background. I also tried reinstalling it and still no use.

Hi Bash,

did you also try the Explorer contect menu?

What version of Gpg4win are you using?
Anything special about the files? (Lost of files in a directory, huge?)


Thank you for your prompt reply.
I’m using version 3.1.10. There is nothing special about the files, just regular word documents and rar files. I’m not sure what you mean by explorer contect menu.

When using the file explorer of windows (depending on your windows version),
the context menu on a file allows you to do crypto operations.

Are you encrypting the files to public OpenPGP keys? (Or S/MIME?)

I am aware of that. But I have to encrypt the files using PGP which is why I am using Kleopatra. And yes I am trying to encrypt them using OpenPGP.
It used to work before but all of a sudden it stopped working peoperly.

Hi Bash,

are you aware of any differences between the time when it works and now?
(Other version of Gpg4win? Different public key?)

The next step of diagnosis (from my point of view) would be to try the encryption
on the command line, e.g. like
gpg --encrypt --verbose --recipient PUBKEY FILE

(Read the output carefully, do not post it fully here unless you removed all personal traces.)


… right. The GpgEX-generated context menu entry in Explorer with “encrypt” does in fact launch Kleopatra for me at least, so…

Is that the “second window” that doesn’t open, then? Kleopatra starting but not producing a window, then thereafter saying it’s running in the background?

Yes, I added my colleagues’ public keys.
I verified some public keys but ignored the rest and added them without verification.
I attached the output I got bellow.


The window that runs in the background is the window where I choose the public keys I encrypt with.

Hi Bart,
thanks for the log, it does not show anything unexpected, the encryption works.
Please also try to add the filename that was not working to the test.


I think the problem lies within the GUI. The window where I select the public keys I want to encrypt the file with automatically runs in the background and is not visible in the task manager.

what version of windows are you using precisely?

Windows 10 version 10.

I’m having the same issue but only when I’m working from home. At work I select the file to encrypt and it opens a second box to select which encryption key to use. At home the second box never loads and when I close Kleopatra I get a box “There are still some background operations ongoing. These will be terminated when closing the window. Proceed?”

I have the exact same problem. Version 3.1.11. One day it was fine. The next, the second window never appears but when I exit the program it gives the same warning message that a process is running. Has there been any resolution to this problem?


yes this was apparently a Problem with high DPI settings. It has been analyzed and a fix for this is scheduled for 3.1.12

Apologies for the inconvenience. We hope to release 3.1.12 soon.