calling Gpg4win from SQL Server


I’m trying to create a SSIS (SQL Server Integration Services) package that creates a Windows batch file on a server and then runs that batch file. The batch file calls Gpg4win which is installed on the server in question.

This works beautifully well when I run the SSIS package as a job using my credentials. When I use the built-in SQL account, SQL Server Service Account, the batch file never runs. (The account that is being used by the Service Account is a domain account that has been granted “full control” to the c:\Program Files (x86)\GNU folder on this PGP server.)

There’s a permissions issue that I can’t solve that is preventing me from being able to use Gpp4win for automated PGP encryption.

The batch file currently look like this:
pushd “\myPGPServer\Temp”
pgp --recipient --always trust --encrypt “MyFileToEncrypt.csv”

I’ve been searcing for a long time for help on this. It seems that everyone has solved the SQL Server Agent account issue is keeping very quiet about their solution.

Does anyone have any insight they can share?