All functionality broken

Search returns nothing, Refresh fails both in the GUI and CLI

An error occurred while trying to refresh OpenPGP certificates.
The output from
C:\Program Files (x86)\GnuPG\bin\gpg.exe was: gpg: refreshing 5 keys from hkps:// gpg: keyserver refresh failed: Server indicated a failure

gpg.exe --refresh-keys
gpg: refreshing 5 keys from hkps://
gpg: keyserver refresh failed: Server indicated a failure

Hello Peter,

do you still have the problem? I tried to reach the server with gpg on Debian and Windows and it worked without any problem. Maybe the server was down at the time you tried to update the keys.

If the problem still occures: Is it possible for you to access the keyserver in the browser ( and what version of GnuPG are you using?

Same issue, no changes.
I can access the keyserver via browser and get valid search results.

Which version of gpg are you using?

You could also try one of these servers:
So you can see if the problem only occurs with the keyserver of Ubuntu or generally.

Win 10 x64
Gpg4Win 4.0.0
GnuPG 2.3.4
Libgcrypt 1.9.4

I tried many other servers before I posted here, same story. I just installed Kleopatra on another Win 10 computer and that works fine so it’s something just with this one machine. I did an in-place upgrade, no changes. I guess I could uninstall and reinstall but will that delete my certs?

Hi Peter,

a deinstallation and reinstallation normally leaves the user data intact.
(Anyway, just make a backup, because the first rule of computer usage is: If you love your data, you copy it.)

Note that there is a rare defect triggered by some changes in Let’s encrypt a few months ago,
which have to do with the TLS certificates and which your windows system has in its store.
(Very technical details in and

However it is also possible that some networking problem exists and blocks access to this port. A personal or network firewall sometimes does this, or usage of a VPN, which changes your network characteristics.

Best Regards,