After installing 3.0 file contained no valid encrypted data error message

We installed on a new machine version 3.0. The person on their old machine had version 2.3.1. We imported the secret key they were using on the old machine to the new, but when we pick the file and choose decrypt, we get the message “file contained no valid encrypted data” If we log the person into their old machine, it works correctly in 2.3.1. Why can’t we get this to work in version 3.0?
We also removed 3.0 and put 2.3.1 on their current machine and it worked for them. They have Windows 10, 64bit.

Hi Ryan,
did you check that the imported public and secret key data worked on the new

For example by encrypting and signing a file and then decrypting it?

Best Regards,

I believe this command worked, so whyt doesn’t it work if you use the GPA or Kleopatra program? I am able to see the data decrypted in the command prompt window. It says something at the top about using subkey xxxxxx instead of primary key xxxxxx

gpg -v --decrypt FILE.enc

Thank you,


Hi Ryan,

if the command line crypto operations work fine, that is good
as it shows that your basic config seems to be allright and you have a

Could file decrypting be a problem of permissions?
(Did you try right click on the file in the explorer?)


The file I am trying to decrypt is on my desktop. When I right click on the file and choose decrypt it does the same thing. See attached. Thoughts?