Adele / GpgEx on Win7 64bits

Good day,

First, is Adele ( down? I’ve sent her 2 emails about 45 minutes ago and still haven’t received a reply :frowning:

Also, I installed the latest Gpg4win (v2.2.1) and found that the GpgEx shell extension is not working. Whenever I try do do anything thru the shell extension, the computer works on the hard drive for a second (so it’s trying to do what I ask) but then Windows says Explorer has crashed :frowning:

Problem signature:
Problem Event Name: APPCRASH
Application Name: explorer.exe
Application Version: 6.1.7601.17567
Application Timestamp: 4d672ee4
Fault Module Name: StackHash_43b3
Fault Module Version: 6.1.7601.18247
Fault Module Timestamp: 521eaf24
Exception Code: c0000374
Exception Offset: 00000000000c4102
OS Version: 6.1.7601.
Locale ID: 4105
Additional Information 1: 43b3
Additional Information 2: 43b35571de31f9638aac8bfaf10ee1ad
Additional Information 3: 4406
Additional Information 4: 4406a396efcf89ebb23dd144e27d1801

Is is supposed to work with Win7-64? With DEP turned on? I’ve had to re-install with the extension removed, but it’s annoying a little…

Thank you.
Best Regards,

Never mind about Adele, she eventually replied :slight_smile:

Now, how about gpgEx, should I try it with DEP off?

Thank you.
Best Regards,

Yes, it is supposed to work on Win7 64bits, with DEP.
However because of the large number of possible configurations,
we may not have tested the particular one you have.

If you are to try without DEP in a way that still keeps your security requirements,
it may help us to exclude that this is a factor in this problem.

ps.: Like my work for Gpg4win?
I appreciate if you flattr us at Thanks!

Good day.

Well, I restored an almost virgin Win7 install and confirmed DEP for all programs was not the issue. Tested some more and found the problem:

I use the environment variable GNUPGHOME to move the home folder to some place I share with all Windows users (mainly, Administrator and my local user). Setting this var makes GpgEx crash. When I un-set, it works.

Can you confirm for me please? Create some folder somewhere, copy your GPG home folder there (from APPDATA somewhere), set the VAR to point to your new folder and try GpgEx?

Thank you much.
Best Regards,

Forgot to mention, as it might be important, when you create the GNUPGHOME variable, create it as a SYSTEM-WIDE variable and then reboot so it’s available to all processes, just so we do the same thing you and I. Let me know if you dont know what I mean.

Best Regards,

thanks for the followup and helping to qualify the problem report!

Note that GNUPGHOME should be a per user setting, and it should be writable
for the user. Maybe that causes the crash in your situation, that it isn’t writable.
Can you check?

Best Regards,
ps.: Flattr Gpg4win at,
if you appreciate my work for Gpg4win.

Good day.

Environment variables are stored in the registry, copied to the kernel’s environment upon boot, then copied to a process’ environment block upon creation. As far as I know, nothing prevents the process from modifying its environment block by calling the appropriate functions. Of course such changes are local; to change the environment permanently you need to call different functions - I’m not sure that there are access rights there, but since I run as Administrator and without UAC, I don’t think access rights is the problem. Just for kicks, I moved my var from a System var to a User var, rebooted, and GpgEx still crashes (Kleopatra has no issues, which is strange because both her and GpgEx call the same modules).

As far as being writable, I find that hard to believe; what does GpgEx need writing to the var for? It’s one of those “read it to find path” vars that should NOT be changed by the shell extension.

Do you have Win 7 64bit? Please try to reproduce; it is much easier for you to try reproducing than it is for me to make changes, re-install Gpg4Win, test, uninstall it, then reinstall it without the shell extension again…


Thank you.
Best Regards,

Hi Sylvain,
it was has an idea that the “system wide” environmental variable could be a cause for the cases. Of course in our tests GgpgEX did not crash. :confused:

With “writable” what I’ve meant is that the applications have to be able to write
to the path that is given with GNUPGHOME. This is why the home is usually per user and not system wide. Of course, this does not explain why Kleo just works for files.

About a test on our side: I could try a test, but I am not sure how it would be different from other tests we’ve done before. Maybe the next idea would be to get a backtrace/crash dump from Gppex somehow.



triggered by this discussion I took a look at this and was able to reproduce it.

This bug has been reported at least three times at I’ve consolidated the reports into the first one:

Please follow up there.

Thanks and apologies for your inconvenience.


Hi Bernhard.

With “writable” what I’ve meant is that the applications have to be
write to the path that is given with GNUPGHOME.

Ahhh, THAT is what you meant! :wink: Well then yes, the folder pointed to by the variable is fully write’able by my user.

I could try a test, but I am not sure how it would be different from
other tests we’ve done before. Maybe the next idea would be to
get a backtrace/crash dump from Gppex somehow.

Let me know if you need any help with this - you would have to explain to me how to get this; I can program on mainframes in COBOL etc, but I know nothing of debugging on Windoze :wink:

Best Regards,

Hi Andre.

Thanks for looking into it.

No rush fixing it for me, I can use Kleopatra to encode if needed, just thought I’d report the problem tho, to be a good user.

Thanks for your hard work on this.

Best Regards,