Unable to read encrypted email in Outlook 2013

Test email is sent from Outlook 2013 with GpgOL v2.0.6 plugin and Exchange 2013 server.

Email is received as attachment and unable to decrypt and read in the same client. Attached is ‘GpgOL Warning’ message upon opening the attachment.

Why attachment? Pls help.



Could you please try again with Gpg4win 3.1.0 (containing GpgOL 2.1.0) from the changelog:

GpgOL: Additional mail types are now supported when reading.


I think that this might fix the problem, otherwise I would be very interested in the debug output of GpgOL:

To get the debug log:

Close Outlook
Open regedit.exe and
set HKEY_CURRENT_USER\Software\GNU\GpgOL enableDebug to either 1 or 1665
set HKEY_CURRENT_USER\Software\GNU\GpgOL logFile to some writeable file (e.g. c:\users\<youruser>\gpgol.txt )
Open Outlook again and open such a mail.

The value of enableDebug → If set to 1 it logs less and should not leak any private data. If set to 1665 the log will contain the plaintext of decrypted messages (and will help more in this case), so only use that if you have a test mail or some unconfidential mail.

If you are not comfortable attaching the log here you can send it to me privately to aheinecke@intevation.de (PGP Key 94A5C9A03C2FE5CA3B095D8E1FDF723CF462B6B1 )


Hi there,

I have the same problem. Encrypted emials sent to me are only visible as attachments. Already tried turn off all plugins and now luck. I don’t use Exchange just regural mail provider. GPGOL ver. 2.2.0

Mails sent form my client to another are properly decrypted.

Hi Jacob,

Could you try to get us a debug log then? :slight_smile:

See the instructions in: https://wald.intevation.org/forum/message.php?msg_id=5889&group_id=11

If you have disabled all other addons and don’t even use exchange I’m very curious what is wrong for you. This is our simplest test setup and it works for nearly everyone else.


Hi Andre,

I fallowed instructions from provided link and I set debug log to 1665. You can find it in attachment to this post.

gpgol.log (1.18 MB)

And this is how it looks like when I open encrypted mail. It’s in Polish but I think it’s not a problem :slight_smile:


Hmm ok, I think I found solution. I had some suspicion in this matter but I wasn’t sure. The problem is made by ESET Antywirus Outlook addon. When I disable it in Outlook, decryption still dosen’t work. But when I disable addon integration with Outlook in ESET Antywirus settings mails are being decrypted properly. I noticed this issue some time ago in Outlook 2010, 2013 and 2016 but mails presented themselfs as a blank page without any attachments so I didn’t connect dots… I will be testing thist case later today to be more sure.

Another update.

Problem with ESET addon is one thing but it don’t cossing my issue. I sent another encrypted email to myself from my friend mailbox and I noticed that when this email shows itself in Outlook main folder decryption works fine but when Outlook recive it and move it to folder using some rules decryptions fails and email is shown as blank with encrypted attachments like in picture I’ve sent before.

Mailbox is set as IMAP.

Thanks. I will try to reproduce it with move rules.

I can see the problem in your log:

06:37:34/1904/mapihelp.cpp:change_message_class_ipm_note: content type is ‘multipart/mixed’
06:37:34/1904/mapihelp.cpp:change_message_class_ipm_note: protocol is ‘application/pgp-encrypted’

Somehow your mail has the wrong content-type. The content-type for a valid PGP/MIME Mail would be “multipart/encrypted” and not “multipart/mixed”

“multipart/mixed” with a protocol parameter is not even defined. So something is clearly changing multipart/encrypted (where the protocol parameter is necessary) to multipart/mixed.

Maybe some gateway or the rules break it.

GpgOL does not handle it when the Mail has “multipart/mixed” content type as it looks for “multipart/encrypted”.

Ok so I’ve done some more tests and now I’m sure that there is some problem with mails moved by rules in Outlook. I’ve turned off the rule for whitch the task is to move mails to dedicated folder and now when I recive a new message it goes to main mailbox folder and decryption works.

I’ve done some tests on Thunderbird with Enigmail to be 100% sure. I made some rules in TB, sent some emails and everything works fine - with and without rules being enabled - so problem is somewhere in Outlook rules I think…

I think with the log you have sent me I can take a stab at fixing it anyway.

If we see multipart/mixed with protocol pgp we can just try to parse it.

I’ll create a version with that in the next few days and will ask you to test it once I have it. :slight_smile:

Ok :slight_smile: No problem :slight_smile:

Hi :slight_smile:

Any news?

I can reproduce the problem but have not fixed it yet.

I’ve opened a task for this: https://dev.gnupg.org/T4070

I’m pretty confident that I can fix it before the next release.