S/MIME Problem


I’ve just installed gpg4win as I needed GPG support for Outlook 2013. I’m already using the integrated Outlook S/MIME Feature. So I’ve installed gpg4win 2.3.0

I was not able to deactivate the gpg S/MIME, which now tries to handle encrypted S/MIME mails. So I’ve uninstalled gpg4win but the problem still exists.

Even if I open weboffice on another computer, the message in the attached image appears. So it seems that somehow gpgol has changed something on my mailbox.

How can i reverse that change?

Kind Regards


GpgOL indeed makes some changes to the messages. Sadly we need to do this. It’s outlined a bit in https://wiki.gnupg.org/GpgOL/MIMESupport

The original S/MIME message is preserved as an attachment. In the case of an S/MIME encrypted mail the name of the attachment would be smime.p7m but GpgOL offers no way to restore the message. This has always been the case with the MIME Support GpgOL had for Ourlook 2007 and earlier version.

I’ve opened a Ticket though because I think we have to make this possible. https://bugs.gnupg.org/gnupg/issue2163

A the only workaround I can think of currently would be to activate GpgOL and send your messages again encrypted to yourself through the Outlook S/MIME mechanism.

I’ve added a note how you can currently disable S/MIME support in GpgOL in the wiki.

But this won’t affect messages already handled by GpgOL :-/

We’ve talked about this Problem in our development team and we think that we should try to fix this.
We will try to change the behavior of the plugin so that it does not permanently store the necessary modifications we have to do for Outlook and restores the original mail again once a mail or Outlook is closed. Preliminary tests on the feasibility of this approach look good. Details are in the bugreport I’ve linked.

This would also work for your S/MIME mails. So stay tuned :slight_smile:


I am also trying to use gpg4win with Outlook 2013 in an exchange environment mixed with other mailboxes (IMAP and ActivSync). I want to use the built-in S/MIME functionality for the exchange mailbox and GPG4win for my other mailboxes.
How should I configure this? I have the problem that when the gpg4win plugin is enabled it always modifies my S/MIME messages and basically corrupts them. I tried to disable S/MIME support in the registry but this does not help. Every S/MIME signed e-mail I open gets corrupted.
I would advise to also insert some kind of warning for data loss on the main page to warn potential new users for this behavior that is irreversible at the moment.


Please try the testversion of gpg4win-3.0.0 https://wiki.gnupg.org/Gpg4win/Testversions

  • GpgOL now has an Option dialog now where you can disable S/MIME Support.

  • When you have disabled S/MIME Support and open a Mail that was touched by GpgOL previously it tries to restore the Mail so that Outlook can handle it again.

Please let us know if this worked or didn’t work for you. We are trying to improve this.


Hello Andre,

thanks for the quick responce, I will install the test version and provide feedback.
Does that mean that in the stable version there is no way to disable the S/MIME handling?