Receiving DLL errors when starting Kleopatra 2.1.0

Hi there,

when i start kleopatra 2.1.0 i receive DLL errors.
I have no idea how to fix this. Deinstalling en reinstalling GPG4WIN will not work.

I am using Windows XP in combination with office 2007.

ScreenHunter_01 Apr. 25 11.41.GIF

I have Tried a few things the past days.

Renaming the Qtcore4.dll and Qtgui4.dll in system32 fixes the problem with kleopatra starting up.
It does create a new DLL issue with another plugin called Digidentity.
This plugin wont start any more when i rename the dll.

Found out the following in the process.

Kleopatra does not install any .dll in system32 but uses these 2 dll’s in that folder. Also seen that kleopatra does install these 2 dll’s but in its own folder. (C:\Program Files\GNU\GnuPG)

Q: why does kleopatra uses the dll’s in system32 when it has its own dll.s in its installation folder?
Why does renaming these 2 dll’s in system32 fixes the problem?

Sollution: make kleopatrta search in its own install folder for the 2 dll’s

ScreenHunter_03 Jun. 26 11.04.gif

Solution: make kleopatrta search in its own install folder for the 2 dll’s

How to do so?

The latest couple of threads on Kleopatra start up problems are very interesting - especially the point about its using dlls other than the ones it writes in its own directory structure.

In the threads about Kleopatra and difficulties with X509 certificates, I was coming to the tentative conclusion that Kleopatra is searching in the wrong place for files and the lengthy delays were perhaps due to files not being found and system processes eventually timing out. I have found that Kleopatra writes at least one file in a location that does not agree with the existing documentation.

Wasn’t Kleopatra originally developed for use with linux systems as part of the KDE environment ? Is it possible that errors have crept in when porting to Windows ?


Please see:

And let us know if this solved your Problem