GPGOL10 bizarre behaviour

Hi all,

If anyone could help me with any idea it would be great. Thanks in advance.
We made our first installations the past week and apparently everything worked fine but our user1 and user2 have different behaviours.

  1. User1: can encrypt email body messages and files. We don´t know if it can decrypt because …
  2. User2: can not encrypt anytihng; we select correctly the options from the GpGOL menus but it does nothing; it decrypts very well …

We have tried the installation several times and nothing changed. We have also tried to work with a third user and, among them, we have obtained the same results.

We are working with Oulook 2010 and Windows XP.

I´ll be willing to listen any answer that could help us,

Best regards, IJC


one way to find out more is to try encryption and decryption on files in Kleopatra first.
(This way you exclude that it is one frontend gpgol that does not work.)

If it does not work there, try it on the command line, also see
which may be a bit technical, though.

Best Regards,
ps.: Flattr Gpg4win at,
if you appreciate my work for Gpg4win.

Hi Bernhard,

Using the encryption-decryption files functionality from the explorer works fine on both of them.

I will have a look to the wiki you have suggested us.

It´s driving me crazy but, anyway, thank you very much.


If it works nicely in GpgEX, then at least your crypto backup setup is fine.

There must be a difference between the two users, regarding Outlook setup or
other applications then.

Thank you very much for your answer Berndhard

I don´t know what to do since we have review de config options several times, 2 persons, and apparently there is no difference betwen the two users except the key-pairs (natrurally).

With reference to the manual I know that one of the steps has been done differently, because the encryption from the user2 did not work. I mean, to explain it …

  • 1st. you create the key-pairs, for user1 and user2
  • 2nd. user1 sends to user2 an email with its public key
  • 3rd. user2, import this public key and reply/send to user1 another email
    with its own public key
  • 4th. user1 receives tis emial from user2, imports this public key and and
    it´s able to start to work with the behaviour explained in my first post …

Do you have any idea about what my mistake could have been?

Thanks, IJC


you written before that encryption/decryption works with files,
which would mean that you certifiates are set up alright. :slight_smile:

Try again: Try User A encryption to User B via Kleo. Send file to user U, try decrypting there. And then vice versa.

Best Regards,
(Flattr Gpg4win at if you appreciate my response.)

Hi Bernd,

Sorry about not answering you before. This week I will try to delete the whole installation on both users.

I think that we´ve alredy done the test you have proposed me:

  • from user1 to user2, and it works encryption en user1 and decription in user2 but the process does not work on the contrary; I mean, from user2 to user1

-we test the product with user3 and the installation process worked fine, at least it says nothing, but then again, it doesn´t work

→ only a small part works: you can encrypt from user1 but you can not send the message to user3 using GpgOL; only to user2, although the decription with user2 does not work and user3 can receive and decript the file (not the email body content) but encryption from user3 does not work.

If you have more ideas please let me know or if you know any other free-software product to recomend me. I´m afraid my organisation wouldn´t let me to continue with much more testing.

Willing to listen from you, best regards


gpgol.log (39.6 KB)

kleo-log (12.5 KB)