GPG - How to get my own key on list?

When I right-click a file to encrypt it with GPG, my own key doesn’t show up on the list. Enabling the ‘encrypt to self’ option doesn’t do anything - only the other keys show up.

I found a workaround, which I also posted in the other thread:

I’m having the same problem. This seems to be a bug, that they wouldn’t have if your key was automatically on the list.

But I found a workaround. Simply designate another key that you’ll never use as your default key.

1.) Export all of your keys to a safe place (like a TrueCrypt volume or some disk nobody knows about).

2.) For step 3 I recommend a file shredder such as Eraser ( You can just delete the files, but that’s not very secure.

3.) Go to your keychain folder (C:/users/lawrencewhatever/appdata/roaming/gnupg) and wipe all of the files in that folder using the file shredder.

If you can’t see ‘appdata’ under your user folder, go to Control Panel > Folder Options and turn on the option to show hidden folders.

4.) After you wipe the gnupg folder, open WinPT. It will ask you to either create a new key, or import a keychain. Create a new key, using a nonsense name and email address.

5.) Import your old keys (not the keychains)into WinPT. Next time you try to encrypt, you should find your favorite key on the list (but not the key you just created).