g_byte_array_ref ; libglib; libgio; claws stuck ; gpg shell gibberish

(in case loc gr_EL)

Yesterday i installed the last pgpg4win package (full install in default places)

claws mail related:

when i open claws 2 error appears
“entry point g_byte_array_ref not found in libglib-2.0.0”
and when i clik ok another one error appear
“error in libGIO~1.dll”
after then claws open and seems work ok (i am new to claws lets see) except spellcheck till now; When i click on compose message button an error say:
“I can’t initialize spellcheck” and i haven’t spellchecker and dictionaries".
I have checked *dic & *.aff files are all in the right place

gpg shell:

on msys
Owner@giannis-b791577 ~
$ gpg
gpg: ╠ΏΎ±ί▀Ϊί Ϊ■±ά Ίά ίώ≤άή▄ήίΪί ΪΎ Ή▐ΊΫΉά ≤ά≥ …

same as in cmd.com
C:\Documents and Settings\Owner>gpg
gpg: ╠ΏΎ±ί▀Ϊί Ϊ■±ά Ίά ίώ≤άή▄ήίΪί ΪΎ Ή▐ΊΫΉά ≤ά≥ …


mmh only one screenshot per post?


and the last about spellcheck when i press compose mess. button


Hi Harry,

re: shell gibberish, there is a known problem with encodings in the shell output.
It probably tries to throw Grek characters at you.

As for Claws issues, have you tried the updated installer from claws website yet?
(We - from the Gpg4win Initiative - just helped to package claws. We sometimes do not manage to build in all possibible features. )

Best Regards,
(Flattr Gpg4win at https://flattr.com/thing/2053326 if you appreciate my response.)

Hi Bernhard, glad to hear from you

shell gibberish :About “It probably tries to throw Grek characters at you.” how can i adopt english localization from gpg? where are the localizzation files that has to do with gpg shell? I not use localized versions of apps instead i prefer plain english (mostly is the default behaviour) localization; i have my reasons for that

i saw in the wild some inconsistencies/problems from people that updated their claws gpg4win copy with the official claws one; you know if is a flawless process or not?

Harry G. K.

i forgot to mention a issue about Kleopatra
i tried to download a friends key but kleopatra dont store it inside so i was forced do it manually his work i.e. i searched finded and copied the key and then imported it in Kleopartra ; doing it in that manner make Kleopatra 's search keys useless

I forgot also to mention that more often claws go stuck and i am forced to kill his process and rerun the program.That’s really a shame

Anyway I want Thank all you for your hard work to port gpg in that particular --Windows users-- world

Best regards
Harry G. K.

the gpg shell as is right now is completely useless


Hi again,

regarding command line:
try the workaround at https://bugs.g10code.com/gnupg/issue1674

Best Regards,
ps.: Like my response?
I appreciate if you flattr Gpg4win at https://flattr.com/thing/2053326 Thanks!

I have just download from http://claws-mail.org/win32/ the officially windows Claws mail version 3.10.1 .

Now i try to substitute merge the new Claws on place of the old one packed with gpg4win “distro”

On purpose a procedure valid for almost all *.exe installers for who not want install --because of the well known Windows registry issues–: Almost all (except very few ) installers with .exe Windows file typing can be extracted with a zipper e.g. 7z

i forgot to mention in gpg4win distributed claws not work also the pop up and in tray new mail notifiers --dunno the other one i not try in out yet-- and the Html viewer is very poor in rendering (This plugin renders HTML mail using the gtkhtml2rendering widget. Version: 0.34) ; compare the output of this renderer and the output of firefox webmail renrderer in the next reply


I will try use the Fancy plugin(based on webkit render engine) and that is available only in the 3.10.1 version i have just downloaded


Thank you Bernhard

Unfortunately that workaround (https://bugs.g10code.com/gnupg/issue1674) has temporary scope i.e. every time you start a new cli(aka command line interface) session have to type SET LANG=C or set LANG=en_US in msys shell; In other words that workaround implies “get dirty” with environment variables or better for have permanent scope(apply for ever) do a *.bat file and include set LANG=en_US
gpg (or git or geany or any executable program name you have to use)

I found a cleaner/simpler workaround valid for almost all FOSS programs and is based on the localization procedure they adopt.
In our case for gpg:

  1. go to C:\Program Files\GNU\GnuPG\share\locale
  2. rename the el directory i.e. in el__NO
  3. you’re done

Obviously i am on a Greek locale and refer to el. Everyone else have to refer in your own localization e.g. de for Germans , it for Italians, fr for Francais etc

When i have time i try the Claws mail substitution 3.9.1 > 3.10.1 . I refer here the output

Harry G. K.

As i mentioned before I have used 7z for extract claws-mail-3.10.1-pkg56 directory from the corresponded *.exe file and i put it in a directory on the desktop. The pretty first time i I had clicked on claws.exe i notice lot of errors. Lets see the times they occurred and the order they occurred:

  1. 2 x http://picpaste.com/3101_1-tGXIgI0H.PNG (in reality that file was present)
  2. 2 x http://picpaste.com/3101_2-rAdCELuq.PNG (entry point not found in libglib-2)
  3. 1 x 2 x http://picpaste.com/3101_1-tGXIgI0H.PNG
  4. error about pgp and other plugins non loaded (no image here)
  5. claws mail finally open and start fetch mails from the IMAP servers (seems definitely very faster than 3.9.1 ; no stucks here)
  6. i try to open the plugins Configuration > plugins and i get that error http://picpaste.com/plugin_error-kMqn5Qel.PNG
  7. i load all the available plugins and get http://picpaste.com/plugin_error2-DNHrqnz7.PNG and similar errors for pgpinline.dll, pgmime.dll, smime.dll . Notice the black squares in the error message correspond in Greek characters (Επιφανεια Εργασιας= Desktop)
  8. I click on a link in a mail to download a file and get http://picpaste.com/dw_error-rCqCG1tX.PNG for every directory i choose;not work also the “open to browser”

Was a great grief because of all that errors but apart of that the program worked well.
Ok i wanted start resolve issues from the grand up so i tried to change the Windows locales to resolve gpg shell’s gibberish, the black squares we
saw in point 7. (and not only) conscious after that some other gibberish would appear(localization issues are hard to deal with if not start in the right way --a clean Windows install choosing english as the wished language–). I will not describe all that procedure but if you are curious i follow a similar procedure as is described here http://www.brighthub.com/computing/windows-platform/articles/46362.aspx

After had changed Windows localization cmd.com start in gibberish mode(as also the microsoft apps crash report dialog) but that is a minor issue i use mostly msys (that remained ok)

Microsoft Windows XP [??δ?σ? 5.1.2600]
(C) π?ε?µατ??? δ??α??µατα 1985-2001 Microsoft Corporation

C:\Documents and Settings\Owner>

C:\Documents and Settings\Owner>dir
? τ?µ?? στ? µ???δα δ?σ??? C δε? ??ε? ετ???τα
? α???µ?? σε??? τ?? τ?µ?? ε??α? BC13-B850

?ατ??? τ?? C:\Documents and Settings\Owner

24/07/2014 11:00 PM .
24/07/2014 11:00 PM …
01/07/2014 01:39 PM 258 .bash_history
14/06/2014 08:35 PM .config
28/06/2014 05:08 PM 1,856 .gitconfig
25/11/2010 12:58 PM 15 .gtk-bookmarks
30/06/2014 10:42 AM 2,256 .kdiff3rc
24/07/2014 10:46 PM .netpanzer
24/07/2014 10:58 PM 2,143 .recently-used.xbel
10/02/2013 08:56 PM 0 .skypecallrecorder.lock
17/02/2013 08:55 PM 505 .skypecallrecorder.rc
29/06/2014 01:36 AM .ssh
17/07/2014 11:26 AM .VirtualBox
17/09/2013 10:39 PM AppData
11/12/2010 09:50 PM 152 default.pls
15/04/2011 09:59 AM Favorites
20/02/2013 06:43 PM Skype Calls
13/07/2014 12:06 PM Start Menu
17/07/2014 10:00 AM VirtualBox VMs
24/07/2014 10:32 PM επ?φ??ε?α ε??ασ?α?
04/02/2014 12:05 PM 85,235,965 ε??τ?σε?? απα?τ?σε?? π?στ?π???σ?? ???ε.pd
04/07/2014 06:04 PM τα ???αφ? µ??
9 α??ε?α 85,243,150 byte
13 ?ατ??? 166,155,087,872 δ?α??σ?µα byte

C:\Documents and Settings\Owner>

Clicked on claws.exe and Woow that time auto-magically no one error was present; the program started flawlessly and start his fetch emails work
The error in point 8 persist. the only one i notice till now :frowning:

The next step is substitute the old claws mail files in C:\Program Files\GNU\GnuPG (gpg4win install directory) with the new ones

Harry G. K.

That behaviour (its not possible edit the previous post after sent)here as if we were in news is weird :frowning:
Anyway point 3. should be:
3. 1 x http://picpaste.com/3101_1-tGXIgI0H.PNG

regarding gpg cmd output: Thanks for documenting another workaround. There are probably still more methods. Of course eventually bugs.g10code.com#1674 will be
resolved some day.

As for claws, I’d suggest to ping the claws people, so they get involved into the


Dear Bernard,

regard CM i followed your suggestion and till now i can say the colin’s CM build works like a charm. Actually i heve it in a “sandbox” but i’ am almost ready to merge it into the gpg4win installation dir. When i do it i refer here the result.
Thank you very much

Best Regards
Harry G. T. Kar