After updating, WinPT detects GPG 1.4.0

And WinPT refuse to work, because the version of GPG must be at least 1.4.2
It’s very strange because the package normally contain GPG 1.4.4 …
I uninstalled all the package and re-installed it but the error always appears.
Can you help me ?

Weird. I tested it on a clean machine and there it worked. WinPT (0.12.3) correctly detected the GPG version. Also the latest WinPT release (1.0.0pre2).

You use gpg4win 1.0.4, right?

Yes, I use gpg4win 1.0.4
As I said, I upgraded from an older version of gpg4win…

I just upgraded from 1.0.1 to 1.0.4 without a Problem. If I remember right, before that I did an Upgrade from 1.0.0 or 1.0.0rc1.
Did you use a Version < 1.0.0 before and did you restart Windows after the Upgrade?


Sure !
Same error.

I resolved the problem.

  1. Uninstall GnuPG
  2. Reboot
  3. Remove the directory GnuPG in the program Files folder
  4. Using RegCleaner remove all entries referring to winpt, gnupg and other
  5. Reinstall.

I just lost some public keys doing that.